[Resolved] 404 error (not found) with Polylang and Really Simple SSL on multi-site

Home Forums General issues 404 error (not found) with Polylang and Really Simple SSL on multi-site

This topic contains 3 replies, has 2 voices, and was last updated by  Mark Wolters 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #151213 Reply

    Richard

    Problem: site unreachable and error message on HTTPS version of second domain (.nl) when using Really Simple SSL in combination with Polylang (HTTPS version of main site .com working fine):

    Not Found
    The requested URL /contact/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Settings:
    cPanel: SSL certificates installed for both .com and .nl domains (Let’s Encrypt)
    Wordpress: changed http:// to https:// in Settings > General
    Really Simple SSL: enabled
    Polylang: The language is set from different domains (English: .com and Dutch: .nl)

    Already tried, without success:
    – Resaving permalinks
    – Resaving Polylang settings
    – Deactivating/re-activating Polylang plugin
    – Updating database records from http:// to https:// with Better Search and Replace plugin

    Description:
    We are running a site with two languages. The main English site uses .com, the Dutch translations (language switcher) redirects to .nl. We are using Polylang with the setting ‘The language is set from different domains’ for this. It worked fine before Really Simple SSL. We have installed an SSL certificate on both of our domains through cPanel. The English site .com works fine in https, but the Dutch site .nl is now completely not reachable. Whatever we try, the error message keeps appearing. We have now restored a backup, so the problem is not visible on the site now (to avoid downtime). If we need to reproduce the problem on the site to investigate, let us know.

    How can we solve this problem?

    #151220 Reply

    Mark Wolters
    Keymaster

    Hi Richard,

    multi-language plugins can cause some issues when activating SSL. Usually re-saving those plugin settings, re-saving the permalinks or disabling/enabling these plugins will solve the issue. There are a number of other possible causes as well, can you check if any if any of the causes listed in this https://really-simple-ssl.com/knowledge-base/404-pages-wordpress-site-migrating-ssl/ article solves your 404 error?

    Mark

    #151315 Reply

    Richard

    Hi Mark,

    Thanks for your reply.

    I will answr to you in-line:
    Usually re-saving those plugin settings, re-saving the permalinks or disabling/enabling these plugins will solve the issue. Already tried all of these (see description in first message) – no success.

    Re-save the permalinks
    Done – no success.

    Photon from JetPack
    Photon not installed.

    .htaccess files in subdirectories
    We deleted .htaccess files in subdirectories – no success.

    Other redirecting plugins

    We disabled all translation/security/caching related plugins (only the core plugins were active) no success.

    Security on your server
    Check if you have hot link protection activated.

    We enabled hot link protection – no success.

    NGINX server settings
    We do not have NGINX.

    What can we still do?

    #151506 Reply

    Mark Wolters
    Keymaster

    Hi Richard,

    if none of the solutions in the article works for you, we suggest to contact your hosting provider about the issue, possibly something is going wrong on the server level. Your hosting provider can check this for you.

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: 404 error (not found) with Polylang and Really Simple SSL on multi-site
Your information: